Libcrypto Openssl

Hello, I am unable to configure LS php 5.3 with openssl on Litespeed Web Server Enterprise v4.2.19 with the following param: '-with-openssl' OR.

Openssl libcrypto.soOpenssl
  • This is the OpenSSL wiki. The main site is this is your first visit or to get an account please see the Welcome page. Your participation and Contributions are valued. This wiki is intended as a place for collecting, organizing, and refining useful information about OpenSSL that is currently strewn among multiple locations and formats.
  • Re: Library dependency problem - libcrypto, libssl Post by TrevorH ยป Thu Jul 03, 2014 2:16 pm No, you have the 32 bit versions listed and it wants the 64 bit versions.

Openssl Libcrypto.so

Well, I'm trying to install a program again, and am having trouble with it finding the dependencies required. The program is called 'drivel', and is a client for www.livejournal.com. I'm currently using the other client, called LogJam, and it works fine, but drivel is a better client, and I would like to upgrade to it.
Well, first off, when installing the RPM for drivel, it complains about me needing two files that I am missing.
libcrypto.so.0
libssl.so.0
After reading around online, it seems to be that these files are installed when you install openssl. I downloaded the source for openssl, extracted it, and configured it for my particular system. It installs perfectly, but still does not install the two aforementioned files that are supposed to be installed along with openssl. I did see a forum on another site that had someone else baffled about the same thing, but no one could solve the problem. Hoping someone here will know what to do.
code:
-----
[[email protected] openssl-0.9.7b]# whereis libcrypto.so.0
libcrypto.so: /lib/libcrypto.so.4 /lib/libcrypto.so.2 /usr/lib/libcrypto.so /usr/lib/libcrypto.so.1
[[email protected] openssl-0.9.7b]# whereis libssl.so.0
libssl.so: /lib/libssl.so.4 /lib/libssl.so.2 /usr/lib/libssl.so /usr/lib/libssl.so.1
[[email protected] drivel]# rpm -i drivel*.rpm
error: Failed dependencies:
libcrypto.so.0 is needed by drivel-0.9.1-1
libssl.so.0 is needed by drivel-0.9.1-1
-----

Libcrypto Openssl Not Found With Path None

Well, I'm trying to install a program again, and am having trouble with it finding the dependencies required. The program is called 'drivel', and is a client for www.livejournal.com. I'm currently using the other client, called LogJam, and it works fine, but drivel is a better client, and I would like to upgrade to it.
Well, first off, when installing the RPM for drivel, it complains about me needing two files that I am missing.
libcrypto.so.0
libssl.so.0
After reading around online, it seems to be that these files are installed when you install openssl. I downloaded the source for openssl, extracted it, and configured it for my particular system. It installs perfectly, but still does not install the two aforementioned files that are supposed to be installed along with openssl. I did see a forum on another site that had someone else baffled about the same thing, but no one could solve the problem. Hoping someone here will know what to do.
code:
-----
[[email protected] openssl-0.9.7b]# whereis libcrypto.so.0
libcrypto.so: /lib/libcrypto.so.4 /lib/libcrypto.so.2 /usr/lib/libcrypto.so /usr/lib/libcrypto.so.1
[[email protected] openssl-0.9.7b]# whereis libssl.so.0
libssl.so: /lib/libssl.so.4 /lib/libssl.so.2 /usr/lib/libssl.so /usr/lib/libssl.so.1
[[email protected] drivel]# rpm -i drivel*.rpm
error: Failed dependencies:
libcrypto.so.0 is needed by drivel-0.9.1-1
libssl.so.0 is needed by drivel-0.9.1-1
-----